Synology DS411Slim and encryption: an unpleasant surprise

Some time ago I built an encrypted volume on my small nas from Synology and today I did the first real test.
I’m backing up an entire volume with Disk2VHD, a nice free utility from Microsoft’s Sysinternals tools to make online volume snapshots.
I did this in the past several times from the same machine on a regular non-encrypted volume on the same nas obtaining about 37 to 40 MB/s of sustained writing speed.

Given the hardware encryption engine included the nas I was expecting a similar performance with the encrypted volume but this is not the case.
The speed is down to 7MB/S, a sharp 80% loss.
I’m running DSM 3.2
I wonder if this is common/expected or not.
The backup will have to be again a nightly activity until I find a way to get back the high-speed when using the encryption 😦

Update: I’ve had the opportunity to test large reads too and it’s not looking good

 

3 thoughts on “Synology DS411Slim and encryption: an unpleasant surprise

  1. Pingback: Synology DS411Slim and encryption: DSM 4.0 not helping performance for me | marcoullasci

  2. Pingback: Synology DS411slim: getting slower with time? | marcoullasci

  3. Pingback: Buffalo LinkStation 220: first impressions | marcoullasci

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s